HONEYSWAP problems

I need help fixing this problem, I couldn’t swap from hny to xdai, but xdai to hny seems fine… When i try to swap on hny to xdai i get this error
“The transaction cannot succeed due to error: undefined. This is probably an issue with one of the tokens you are swapping.”

1 Like

There have been issues with the RPC recently. Try changing to any of these:

https://rpc.xdaichain.com/
https://dai.poa.network/
https://xdai.poanetwork.dev/
https://xdai.1hive.org/
https://rpc.xdaichain.com/

Try also clearing your browser cache, and if those don’t work try going to Metamask settings > Advanced > Reset Account

1 Like

You can also find support 24/7 on the Discord #help channel. :wink:

1 Like

The same problem happened to another user. He changed all 4 rpcs, reset metamask, empty cache and a number of other things. I’ll check if he found a solution, maybe it’s only a matter of time and then things work again. Keep us on the loop on this one!

1 Like

im already a member of the community… thank you :))

tried these… and everything didn’t work

yes i tried everything and still nothing… @,@ i already got a help from the discord community and still the the problem wasn’t solved…

Try a different wallet, and try transferring your HNY out of this wallet somewhere else. You may have voted in a dandelion vote which locks your tokens.

1 Like

@anisoptera do you have the link of the dandelion proposal or something?

There are a few, it says underneath the proposal that it’ll lock your tokens. Did you try sending the tokens somewhere else and get a failure?

haven’t tried it yet

hey mate! did u fix it? Im having the same issue here :frowning:

it did… its because of the celeste voting that locked the token… in your case maybe you voted on 1hive or just rpc error…

when it locked in celeste
it doesn’t show that amount in your hny balance,right?

That’s correct, it will disappear from your hny balance if it’s locked in celeste

I’ll also note that Meta Mask is the preferred extension. There are a few others that seem to work like Alpha wallet. Notably (sadly) Math Wallet does not work since there’s a handshake issue with no confirmation taking place.