I lost all my crypto becasue of a TREZOR bug - NEED HELP PLEASE (Customizing NONCE on METAMASK didn't solve it)

Here’s what happened:

  1. I made two USDC transactions trough the eth network. The first one was made with a very low gas fee (11 gwei). So now they’re both stuck.

  2. After that I tried to bump the fee on Trezor, but it says I don’t have enough funds. I actually do, but it seems this is a common and very unacceptable Trezor bug.

  3. So after that, I read through the forums and tried using metamask to make a new transaction with the same NONCE as the first one with much higher gas fees, so the first transaction would be replaced. The problem is that’s not working, I tried like 30 times with many differrent GAS parameters, and none have worked, here is the error message that always happens:

Transaction failed! [ethjs-query] while formatting outputs from RPC ‘{“value”:{“code”:-32000,”message”:”replacement transaction underpriced”}}’

  1. Then I found out that no matter the inputs I set to gas fees, the transaction always come out with 0 gas fees in the “total gas fee” and " max fees per gas". Somehow it always come out with the Gas Limit of “50000”, which is the value that I set on my first try at metamask and it never changes.

  2. So LONG STORY SHORT: Trezor’s bug don’t allow me to bump the fees, and the NONCE strategy on METAMASK also failed me. All my crypto is in the eth netwrok on trezor, so if I don’t figure this out I will lose all of it. I’m desperate guys, I’d really appreciate some help here.