Faucet claim transaction stuck

I tried claiming from the faucet yesterday. Transaction didn’t is still showing as pending in Metamask. It does not appear in BlockScout. Tried several times cancelling it, didn’t work.
Now my Metamask address is completely broken.

1 Like

Looks like there are some network problems lately. If you have problems in the transactions, you can refer to this guide.

Already done that. Didn’t help.

hey bud… you may get more support from Discord. Try out the #help channel.
In my opinion, you have listed all the information:

  1. You may have a tx that is stuck if you had tinkered with gwei and gas limits.
  2. Generally if you reset metamask account under settings>Advanced>Reset Account. Just read the info before you do that.
  3. All else fails and you still have a stuck tx, it may be worth googling for metamask wallet stuck tx, i know @defi_dad had a simple video that showed how to send yourself another transaction with the same nonce with the right gas price and limit and generally once that tx is picked up and cofirmed it fixes the issue.

Hope you get resolution in #help.