Troubleshooting problems on Metamask

Yes, I can confirm that by deleting the xDai chain config in MetaMask and adding the same xDai chain config again solves the connectivity issues.

1 Like

I had the same ID chain issue. I solved it by simply changing “100” to “0x64”. Thanks for this useful troubleshooting post :+1:

1 Like

Well thanks for this, works for me.

1 Like

Thank you for your help metaverde

1 Like

Thanks guys, I’ve added a section for this in the guide now just in case more people have this issue :slight_smile:

EthQuery - RPC Error - Error: Unsupported chain id (shows in Metamask advanced settings + scr bellow), using Metamask with Trezor T v2.3.4

Using Metamask with Trezor Model T connected. Eth mainnet all OK, DAI to xDai bridged seems OK, xDai shows in my wallet while switched to xDai chain…but not able to send any transaction. I tried everything. Different RPC settings, reset metamask, disconnect, clear cache and history, used both Firefox & Chrome, sent 0.01 from xDai faucet (received ok), nothing helps.

ISSUE resolved: Trezor T v2.3.3 won’t let you sign transactions on a different derivation path than the original one of the chain that the coins are supposed to be at. Understand, Trezor cannot handle xDai chain trxs. Source&details:

SOLUTION: Downgrade Trezor T firmware to v2.3.0 (only works for Model T)

I have struggled for almost two days dealing with this, a lot of pain. I edit my call for help now to make this clear, hoping nobody else would suffer like me :slight_smile:

IMPORTANT Offical Trezor wiki page provides incorrect files, don’t go there!!! :rage::
The best and step by step clearly described procedure with correct files:

I have downgraded v2.3.4 to v2.3.0 finally, my wallet was not erased, no need recovery (but anyway, have your seed/passphrase/etc recovery credentials ready for the case!!!)

Good luck and hope this helps somebody.

1 Like

make sure Chain ID 100

1 Like

Firefox behavior While i input “100” chain id in Metamask on Firefox, it changes itself into hex value “0x64” (seen when i open settings again)
Chrome behavior When i input “100” chain id, it remains “100” value in the settings

I don’t know correct Metamask behavior, but when i click on trx details, i would expect to open blockscout page, however it opens etherscan?!? Is that correct? Metamask bug??

Hello, I have a problem, I swaped the HNY token in honeyswap, first time it asked to approve HNY, metamask evoked a spend limit, now I think here I made a mistake instead of unlimited spending I chose limited and entered 1 I guess or 10… I don’t remember. Now I can’t swap HNY normally, I get approve HNY button everytime I try to swap more than 0.0007 HNY or something. By the way Approve HNY button doesnt work in V2 anymore for me, but it works in V1, but no liquidity there… please help, is there an external tool to manage spend limits?

1 Like

Appreciate the work Blazer. It’s very useful information for the new comers. Keep up the good work :sunglasses:.


Hi, Gigadig. I have the same issue. It’s not a mistake on your side. Limited Approval is a good practice to keep funds under control.
It works well on Uniswap, but unfortunately triggers some issue here on Honeyswap. Did you fix it or get some useful advice? If yes, please kindly share.

Dear @admins , do you have some comments on it? I’ve already checked all obvious methods (clear cache, refresh, restart browser, reinstall Metamask, etc.). Uniswap works great in the same conditions. Really appreciate any useful advice. Thank you.

Sorry, i didn’t understand it correctly. I have not experienced any approval issues yet.
But when i needed to change token permissions on Eth mainnet, i used succesfully the dapp bellow:

You can cancel approval for your tokens, however i don’t know if it works on xDai as well.

Hi @matthew and @Gigadig,

Sorry for the delayed response but we usually do not do support on the forum, it’s more for discussing ideas/proposals and posting guides. You get much faster help if you ask in the #help channel on the Discord, which I would like you to do when you have the time so we can have faster communication and resolve your issue, otherwise we will experience a delay in communication since we’re probably not on the forum at the same times :slight_smile:

Again, sorry for the delayed response


Adding a contact to Metamask.
I think it’s a less known feature, but a very useful one. You can save an address in your contacts list, which will make it easier for you when you want to transfer something to that address in the future and also it will make it impossible for you to send the tokens to the wrong address.
Here is how :

Many thanks to own thread


Honey farm doesn’t seem to be loading today? Problems?

Yes the graph looks to be down currently - farms, info.honeyswap and the faucet are all affected, try again in a few hours. It’s more likely to be an issue with the wider xdai network as opposed to honeyswap specific

Thanks for this elaborate guide, it answered almost all of my question. What a great community this is.

1 Like

Blazar,thanks your Metamask troubleshoot sorted my problem after days of getting HNY claim failures

1 Like